Récemment, nous avons eu un souci lors du redémarrage d'une instance CA Identity Manager.
D'une part, l'annuaire UserStore ne veut pas se lancer. Lorsqu'on tente un démarrage avec la commande dxserver start, on a le message :
dxserver start userstore
Message
userstore does not exist
On vérifie bien que la configuration est là, que les fichiers de données sont également présents... Pas de processus en cours d'exécution.
Par contre, il y a un fichier userstore dans le répertoire DSA_HOME/pid. Lors du démarrage, le processus vérifie si ce fichier existe et s'il y a un process unix correspondant, ce qui n'est pas le cas... et il s'arrête.
Il suffit alors de supprimer le fichier et de relancer.
# su - dsa
$ cd pid
$ ls -l
userstore
$ rm userstore
$ dxserver start all
Starting all dxservers
userstore starting
.......
userstore started
$ dxserver status
userstore started
Une fois le problème de l'instance d'annuaire résolu, l'application ne se déploie toujours pas correctement. Dans le fichier de logs du serveur JBoss, on trouve des choses comme :
HQ142032: Error reading journal file: java.lang.IllegalArgumentException
at java.nio.Buffer.position(Buffer.java:244) [rt.jar:1.8.0_73]
HQ224000: Failure in initialisation
Il semble y avoir des incohérences dans les fichiers journaux de HornetMQ.
J'ai tenté de renommer le répertoire messagingjournal :
cd /app/EAP-6.4.0/standalone/data
mv messagingjournal messagingjournal-OLD
Puis redémarrage du JBoss. Le répertoire messagingjournal est recréé, et l'application s'est bien déployée.
La cause probable de tout cela : un arrêt intempestif et brutal des procecss ou de la machine (reboot un peu trop "hard" ?) qui a laissé des fichiers dans un état incohérent.